Hosted agent builds failing in US East

Incident Report for LiveKit

Postmortem

Summary

An issue with the image registry which powers our hosted agents offering temporarily caused new hosted agent builds in US East to fail. Existing agent workloads were not affected, and no sessions or calls were impacted.

Timeline (UTC)

  • 19:54 - Hosted agent builds begin failing in US East
  • 20:48 - Our team noticed the increased failure rate and began investigating
  • 21:04 - First mitigation deployed
  • 21:08 - Most builds succeeding
  • 22:14 - Second mitigation deployed, covering the remaining affected infrastructure
  • 22:24 - All builds succeeding

Scope of Impact

Only new hosted agent builds and deploys in US East were affected. Agents already running were unaffected, as were all sessions, calls, and other regions. Customers who were impacted would have seen their deploy fail with “unable to deploy agent: an error occurred while building your agent, please try again”.

Mitigations and Follow-ups

  • We are improving alerting on build failures.
  • We are improving monitoring of our downstream image registries.

We appreciate your understanding and are committed to continuously improving our platform's reliability. If you have any questions, please reach out to our support team.

Posted Aug 17, 2026 - 10:15 PDT

Resolved

We pushed a second mitigation at 22:14 UTC and all US East builds have been successful since 22:25 UTC. We will follow up with a postmortem describing the timeline, root cause, and follow ups as soon as possible.
Posted Aug 14, 2026 - 16:01 PDT

Update

The total build error rate has decreased significantly due to the mitigation, but a small percentage of builds in US East are still failing. We are continuing to monitor and will follow up with another update as soon as possible.
Posted Aug 14, 2026 - 14:41 PDT

Monitoring

We have deployed a mitigation and builds are now successful. We will continue monitoring while we collect any further details to share.
Posted Aug 14, 2026 - 14:15 PDT

Identified

New hosted agent builds are failing in US East. Existing agent workloads are not affected. We are currently deploying a mitigation and will follow up with more information shortly.
Posted Aug 14, 2026 - 14:10 PDT
This incident affected: Regional Cloud Agents (US East - Cloud Agents).