Analytics dashboard updates delayed

Incident Report for LiveKit

Resolved

Analytics dashboards are updating normally again.
Posted Feb 26, 2026 - 18:40 PST

Identified

Updates to the LiveKit Cloud analytics dashboards are currently delayed due to an issue with our processing pipeline. Ingestion of new data is not affected, and we are in the process of recovering all data.

We'll share another update once the restoration is complete and dashboards are updating normally.
Posted Feb 26, 2026 - 16:18 PST
This incident affected: Cloud Dashboard (cloud.livekit.io).