Investigating longer than usual dashboard loading times

Incident Report for LiveKit

Resolved

An internal one-off analysis job ran some expensive DB queries which slowed down load times of the dashboard's sessions page. The job was removed and load times are now back to baseline.
Posted Jul 30, 2026 - 15:25 PDT

Investigating

We are currently investigating longer than usual dashboard loading times. No services appear to be impacted and we don't expect any data to be lost.
Posted Jul 30, 2026 - 11:53 PDT
This incident affected: Cloud Dashboard (cloud.livekit.io).