Degraded Performance LiveKit Cloud dashboard

Incident Report for LiveKit

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 02:45 PDT

Monitoring

A fix has been implemented and we are monitoring the result
Posted Mar 30, 2026 - 02:20 PDT

Update

We are continuing to investigate this issue.
Posted Mar 30, 2026 - 02:09 PDT

Investigating

Users may be unable to access the dashboard. Our team is actively investigating.
Posted Mar 30, 2026 - 02:09 PDT
This incident affected: Cloud Dashboard (cloud.livekit.io).